Tue. Jun 25th, 2024
Android 15 to block app downloads for outdated OS versions

Google is taking steps to enhance security and compatibility with newer versions of Android by raising the threshold for parallel downloads of apps targeted at obsolete versions. Starting with Android 15, apps must target at least Android 7.0 Nougat to be downloaded in parallel. This change was introduced in the second preview of Android 15 Developer, aimed at blocking the installation of apps from outside the Google Play Store with an SDK level lower than 24.

Android 6.0, released in 2015, brought significant changes to the operating system, including improvements to battery life and stricter privacy requirements for app permissions. The changes coming with Android 15 aim to further enhance security and compatibility with newer versions of Android. Google previously made similar changes with Android 14, raising the threshold to level 23, equivalent to Android 6.0 Marshmallow. Now, apps must be compatible with at least Android 7.0 Nougat to be downloaded in parallel.

Google’s ongoing efforts to improve security and ensure a better user experience for Android users are reflected in these changes. By setting higher compatibility thresholds, Google aims to protect users from potential security risks associated with outdated app versions and maintain the integrity of the Android ecosystem.

By Aiden Nguyen

As a content writer at newscholarly.com, I delve into the realms of storytelling with the power of words. With a knack for research and a passion for crafting compelling narratives, I strive to bring forth engaging and informative articles for our readers. From decoding complex concepts to unraveling current events, I aim to captivate and educate through the art of writing. Join me on this journey as we explore the ever-evolving landscape of news and knowledge together.

Leave a Reply